Incorrect date value 0000-00-00
错误描述:
MySQL 返回:
#1292 – Incorrect date value: ‘0000-00-00’ for column ‘start_date’ at row 1此错误是因为 MySQL5.7 版本及以上版本的 datetime 值不能为 ‘0000-00-00 00:00:00’。
解决办法:
找到配置文件中的 [mysqld] 括号后,[mysqld] 部分最后添加下面的代码:
sql_mode=”ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION”
重启 SQL 服务。